September 25, 2020


Xolo LT900 smartphone with 4G LTE support, Android 4.2 launched at Rs. 17,999

xolo-lt-900-listed-635Xolo has officially launched its first smartphone with 4G support in India, the LT900 at Rs. 17,999. The highlight of the Xolo LT900 is that it supports TDD LTE bands, and is the first smartphone in company’s LT smartphone series.

The Xolo LT900 has been listed on the company’s site with pricing details, however, without word on the availability of the smartphone.

The 4G-enabled smartphone runs Android 4.2 Jelly Bean out-of-the-box and supports single SIM (GSM) functionality. The Xolo LT900 is powered by a 1.5GHz dual-core Qualcomm MSM8960 Snapdragon S4 processor with Adreno 225 GPU (clocked at 384 MHz), which are coupled with 1GB of RAM. It features a 4.3-inch HD (720×1280) IPS display with One Glass Solution (OGS) and boasts of Corning Glass protection.

Xolo’s LT900 sports an 8-megapixel rear autofocus camera with dual-LED flash and BSI sensor, while it also houses a 1-megapixel front-facing camera. The smartphone includes 8GB of inbuilt storage that is further expandable up to 32GB via microSD card. It packs an 1810mAh battery which the listing claims can deliver up to 15 hours of talktime and up to 362 hours of standby time on 2G networks.

Apart from 4G network support, connectivity options on the Xolo LT900 include Wi-Fi, Bluetooth, GPS/ AGPS and 3G. It comes with dimensions 128.7x66x9.8mm. The Xolo LT900 comes preloaded with Skype, BigFlix, Kepplr Cloud Space and Airtel Mobile TV apps.

Xolo recently launched the Opus Q1000 budget phablet at Rs. 9,999. The Xolo Opus Q1000 runs Android 4.2 Jelly Bean and is a dual-SIM phablet with support for GSM+GSM. It features a 5-inch FWVGA IPS display with 480×854 pixels resolution. The Xolo Opus Q1000 continues the Q range tradition and equips a 1.2GHz quad-core Broadcom BCM23550 with Videocore IV GPU and 1GB of RAM.

Source-NDTV

2 thoughts on “Xolo LT900 smartphone with 4G LTE support, Android 4.2 launched at Rs. 17,999

  1. Hello just wanted to give you a quick heads up. The text in your post
    seem to be running off the screen in Internet explorer.
    I’m not sure if this is a format issue or something to
    do with browser compatibility but I thought I’d post to let you know.
    The design and style look great though! Hope you get the issue solved soon.

Leave a Reply

Your email address will not be published.